X/Twitter Content Disruption in API

Incident Report for Meltwater API

Resolved

After a period of monitoring, this issue is now resolved. Our Engineering team has processed the backlog, and X/Twitter is flowing into the platform as expected.
Posted Oct 17, 2025 - 09:35 UTC

Update

X/Twitter content continues to flow into the platform as expected. Our Engineering team is actively processing the backlog for missed content. We will continue to monitor and provide updates accordingly.

Thank you for your patience.
Posted Oct 16, 2025 - 15:31 UTC

Monitoring

X/Twitter content is flowing into the platform as expected. We will continue to monitor the application and provide updates accordingly.

Thank you for your patience.
Posted Oct 16, 2025 - 05:18 UTC

Investigating

We are currently experiencing an issue with receiving X data, which may cause a delay in the latest X data appearing in searches in API. Our Engineering team is aware of the issue and is actively working to resolve it. We will share updates as they become available.

We apologize for the inconvenience and thank you for your patience.
Posted Oct 15, 2025 - 11:32 UTC
This incident affected: Meltwater API Listening Streaming (API endpoints, Content Stream) and Meltwater API Listening Analytics, Meltwater API Listening Exports, Meltwater API Listening Search Management, Meltwater API Account Management, Meltwater API Owned Social Analytics, Meltwater API Listening Search.